1
0
mirror of https://github.com/TREX-CoE/trexio.git synced 2024-12-21 20:04:05 +01:00
trexio/flake.nix
Phillip Seeber df0e3a8e1c
add nix build instructions and README section (#173)
# Conflicts:
#	README.md
2024-12-11 16:15:12 +01:00

24 lines
527 B
Nix

{
description = "TREX I/O library";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
let overlay = import ./tools/nix/overlay.nix;
in flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs {
inherit system;
overlays = [ overlay ];
};
in
{
packages.default = pkgs.trexio;
}
) // {
overlays.default = overlay;
};
}